Slackers (Slackware current journal) - Slackware – GNU/Linux per SubGeni e Fannulloni

GCC 4.4 e problemi di compilazione

In un articolo del suo sito, Martin Michlmayr, sviluppatore Debian, mostra come ricompilare l’archivio Debian con il GCC 4.4 (versione di sviluppo) porta alla scoperta di molti build errors.

Che poi è lo stesso motivo per cui Pat non ha inserito ancora in -current GCC 4.3

The gcc-4.3.x branch is much more strict about source correctness, and many upstream sources would need to be patched in order to compile with it. Therefore, this is the logical next compiler to use until those issues are worked out upstream. Adding gcc-4.3.x at this time would be, IMHO, an annoyance for many people compiling their own sources or packages.

Anche perché in Slackware è “quasi” tutto vanilla, senza le numerose patch che invece fanno parte da sempre del mondo Debian.

La domanda che viene spontanea è: quanto i progetti opensource dovrebbero aggiornarsi in base al GCC o quanto GCC dovrebbe essere meno “strict”?

Lascia un commento

TrackBack URI

XHTML: Puoi usare questi TAG: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Slackware Linux Wordpress Get Firefox! XHTML CSS Newartonline Conraid